React-demo-store is not working after upgrading sdk to 3.15.2 because the methods are invalid

#1

I integrated the react-demo-store logic from github into my website.
And upgraded the sdk verstion to 3.15.2.
Soon after that it has problems with getting cart items and addcart etc.
According to moltin api reference they use “reference” parameter for getting cart items but that parameter was not in the react-demo-store v2.3.0.
How can I solve this problem?
Thank you very much in advance.

0 Likes

#2

Hey @dale-carnegie! Thanks for flagging this and wonderful to see you getting up to speed with Moltin. That demo store is one of our oldest and quite frankly needs some TLC to be brought in line with the newest versions of the SDK. I know the developer success team (cc. @notrab) are looking at revamping it this quarter so stay tuned.

In the meantime we’d invite you to browse the other projects in https://github.com/moltin-examples and perhaps @notrab can advise you further!

All the best,
Matt

0 Likes