ERROR: Command CompileSwiftSources failed with a nonzero exit code


#1

Hello,

Any advice on how this can be solved?


#2

Hi @Sellitch,

Would you be able to tell me how you’re attempting to run the SDK? Looking from your screenshot, you’re trying to run the SDK framework itself rather than the example project (you can verify this by switching to the example iOS project in the scheme dropdown in the top left).

As we don’t use any external libraries in our SDK anymore we don’t need bridging headers anymore - however, I did notice your previous forum thread which mentioned that you were running one of the earlier versions of the SDK, I’m wondering if these are just some assets kicking about from then. Would you be able to clean your build folders in the “Product” menu and run this again?

Thanks,
Craig


#3

Hi Craig,

I have verified this.

I have also cleaned the build folders on a number of occasions.

I am running the latest versions of SDK now rather than what was mentioned in the last forum.

Do you have teamviewer installed or something similar so you could look into this?

Thanks,

Connor


#4

Hi @Sellitch

Could you try setting up a fresh project using the instructions found here? https://moltin.com/quick-start/swift/

This has been confirmed to be working correctly and should fix any issues you are having.

Thanks

Drew


#5

Hi,

I am new to this so i will need time.

I think i have followed the steps but i’m now coming across this error:


#6

Hey @Sellitch,

Looks like there’s a slight typo in our quick start guide, as that should be a lowercase m - import moltin. I’ll get that updated on the site ASAP!

In the meantime, you could check out our example iOS app as a reference.

Hope this helps,
Craig


#7

Hi Craig,

Sorry to be a nuisance, the issue still exists.

Any other workarounds?

Connor


#8

Hi @Sellitch

Can you give us some more information about how you are trying to build the project?

Just to confirm import Moltin has been changed to import moltin?

Thanks

Drew